LaserSafe PC upgrade from version 4.0 to 5.4

Version 4.0 and all previous versions are now obsolete and do not conform to the latest Laser Safety Standards. See standards below.

Depending on your existing version you may find that it does not comply with the latest internationally accepted laser safety standards.

If you have LaserSafePC version 4.0 or earlier please read below for the benefits of upgrading.  If you have version 5.0 or above, please read here.

To check on the version number please start the LaserSafePC program and click “Help” and then “About LaserSafe PC”.

Upgrading to 5.4 will provide you the following benefits:

1

Compliance to these Standards:

IEC 60825-1 : 2014, EN 60825-2 : 2004 + A2 : 2010,

ANSI Z136.1 – 2014 and

CDRH 21 CFR § 1040.10.

Includes IEC 60825-1 : 2001 and IEC 60825-1 : 2007, for reference.

You can perform calculations to one standard and then see if your results comply with other standards. This is important if you need to comply with standards in Europe as well as the USA and the rest of the world.

2 EN207 : 2017 Standard for Personal Eye-protection Equipment and Filters.

Ideal to identify the laser safety eyewear and filters you need to prevent injury.

3 Introduction of in-depth details and information on the Product Classification.
4 Introduction of Hazard Level analysis window for Fibre Optics
5 Introduction of Laser Safety Warning Signage result screen.

You can determine the Equipment or Enclosure Sign you must have to conform to the appropriate standard.

6 Introduction of “Help Bubbles”.

Instant help with units conversions and viewing of miscellaneous details.

7 Introduction of converging beam calculations on Point Source calculator.

Uses M2 factor for multimode beams and deals with real world diffraction limited scenarios.

8 Inclusion of Lens Calculator for processing laser beams.